Results 1 to 2 of 2


  1. #1
    Join Date
    Dec 1969


    Iam executing a Oracle PL/SQL procedure through ASP. PL/SQL head is as follows:<BR>---------------------<BR>PROCEDURE fetch_wod_svc_typ1(<BR>p_wod_nr IN tampybl.wod_nr%type,<BR>p_wod_suf_nr IN tampybl.wod_suf_nr%type,<BR>p_return_code OUT number,<BR>p_return_text OUT varchar2, <BR>p_wod_svc_typ_cd OUT t_wod_svc_typ_cd);<BR>----------------------------<BR><BR>This PL/SQL returns "t_wod_svc_typ_cd" which is a table of rows(returns PL/SQL table).<BR><BR>when i tried using command object of ASP.<BR>1. cmd.commandType = 1 (adCmdText)<BR>gives me an following error:<BR>[Microsoft][ODBC driver for Oracle][Oracle]ORA-02005: implicit (-1) length not valid for this bind or define datatype<BR><BR>I guess it is because it returns one PL/SQL table and 2 other single value..<BR><BR>2. when i tried using <BR>cmd.commandType = 4 ( adCmdStoredProc)<BR>gives me an error, (because it returns table of rows so i think i cant able to execute in this way)<BR><BR>--------------<BR>now my question is<BR>is it possible to execute an ORACLE PL/SQL which returns PL/SQL table as well as single value text or number value. <BR>iam using Micrisoft ODBC conenction.<BR><BR>any help wud be appreciated. Thanks.<BR>

  2. #2
    Join Date
    Dec 1969

    Default Crosspost<eop>


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts