What did I mess up??

Results 1 to 3 of 3

Thread: What did I mess up??

  1. #1
    Join Date
    Dec 1969

    Default What did I mess up??

    I am creating a web site, and for the life of me I can not figure out what I messed up. I have two copies of our web page- on in a development folder, the other that the public views.<BR><BR>The other day I made some changes to the development, and I updated the web site. However, a page that I did not make changes to, one that updates a database, no longer works.<BR><BR>When I hit the submit button on the form to update the databse, I am now getting:<BR><BR>Microsoft OLE DB Provider for ODBC Drivers error &#039;80004005&#039; <BR>[Microsoft][ODBC Microsoft Access Driver] Cannot update. Database or object is read-only. <BR><BR>Nothing is set to read only, so far as I can see. I am using the same code that I was using before. Does anyone have any idea how I managed to make this mess?<BR><BR>Here is the code that was working but no longer does:<BR><BR>Set objAdminConn = Server.CreateObject("ADODB.Connection")<BR>objAdmi nConn.Open "DSNAdmin" & strClientName<BR> <BR>Set rsAdmin = Server.CreateObject("ADODB.Recordset")<BR><BR>rsAd min.Open "SELECT * FROM admin WHERE ClientName = &#039;" & strClientName & "&#039; ", objAdminConn, adOpenDynamic, adLockOptimistic<BR><BR>...<BR><BR>rsAdmin("FieldN ame") = Request.Form("FormName")<BR>rsAdmin.Update

  2. #2
    Mark Guest

    Default RE: What did I mess up??

    I had a similar problem when I was developing a db application for the web. I think what i did was reupload the database to the web server. Hope this helps...

  3. #3
    Join Date
    Dec 1969

    Default RE: What did I mess up??


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts