Help, can't connect asp to database

Results 1 to 3 of 3

Thread: Help, can't connect asp to database

  1. #1
    Join Date
    Dec 1969

    Default Help, can't connect asp to database

    I had a NT 4 machine with IIS and SQL installed, everything were OK. Now, I had to move all asp&#039;s to W2K server, but leave SQL on NT server. I&#039;ve corrected all variables (like connectionString etc) so I believe all asp are correct. But whatever I do, I keep getting this error:<BR><BR>"Multi-step OLE DB application generated an error. bla-bla...No work was done."<BR><BR>I thought, the problem was in MDAC, so i&#039;ve updated it to 2.6, but it didn&#039;t helped much. My IIS autentification is set to basic, so it is not the source of trouble.<BR><BR>I hope you can help me with this one.<BR><BR>Thanks, Vlad.<BR>

  2. #2
    Kalin Guest

    Default RE: Help, can't connect asp to database

    hello. here are some questions to help you troubleshoot.<BR><BR>were you running DSN, or DSN less connections? <BR>Is SQL running on TCP/IP?<BR><BR>Can you create an ODBC connection from the web server to the sql server?<BR><BR>this is an example of a dsn-less SQL connection:<BR>sql_connect="DRIVER=SQL Server;SERVER=;DATABASE=example_db;UID= sa;PWD=passme;"<BR>

  3. #3
    Join Date
    Dec 1969

    Default 2 Kalin

    Thanx for paying me attention, here are the answers:<BR><BR>1. no there&#039;s no DSN<BR>2. I&#039;ve tried both TCP/IP and Multiprotocol.<BR>3. Here&#039;s the code i use:<BR><BR>Function ApplicationSettings()<BR> Application("ConnBtl_ConnectionString") = "Provider=SQLOLEDB.1;Server=some_srvr;Initial Catalog=btltest1;Data Source=some_srvr;Locale Identifier=1049;Connect Timeout=15;Use Procedure for Prepare=1;Auto Translate=True;Packet Size=4096;User Id=some_uid;PWD=some_pwd"<BR>....<BR>bla-bla-bla<BR>....<BR>End Function<BR><BR>Function NewConnBtl()<BR> Set ConnBtl = server.CreateObject("ADODB.Connection")<BR> ConnBtl.ConnectionString = Application("ConnBtl_ConnectionString")<BR>.....<B R>bla-bla-bla<BR>.....<BR> ConnBtl.Open &#060;-This is the point, when i get an error<BR>End Function<BR><BR>I&#039;ve also tried to connect through DSN, it didn&#039;t helped much.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts