Global ASA not working

Results 1 to 2 of 2

Thread: Global ASA not working

  1. #1
    Join Date
    Dec 1969
    Posts
    2

    Default Global ASA not working

    &nbsp;<BR>I can&#039t seem to get my global.asa to work. I can&#039t set any session variables.<BR><BR>Here is my global.asa file<BR>----------------------------<BR>&#060;SCRIPT RUNAT=Server Language=VBScript><BR>Sub Application_OnStart<BR><BR>End Sub<BR><BR>Sub Application_OnEnd<BR><BR>End Sub<BR><BR>Sub Session_OnStart<BR> Session("Mike") = "hello world"<BR>End Sub<BR><BR>Sub Session_OnEnd<BR><BR>End Sub<BR>&#060;/SCRIPT><BR><BR>-----------------------------------------------<BR>here is the file that should write that out<BR>--------------------------------------------<BR>&#060;script language="VBScript" RUNAT="Server"><BR><BR>Dim SessProp<BR>Dim key<BR><BR><BR>For Each key in Application.Contents<BR> Response.Write(key)<BR>Next<BR>Response.Write("<BR >root=" & Application("APPLICATION_ROOT"))<BR>For Each SessProp in Session.Contents <BR> Response.Write("<BR>Session " & SessProp & _<BR> " = " & Session(SessProp))<BR><BR>Next<BR>&#060;/script><BR><BR>For that matter, I can seem to read an application variables either. <BR> Perhaps the server has to be set up to allow for global.asa?<BR><BR>Thanx,<BR><BR>MIchael Russo<BR>

  2. #2
    Join Date
    Dec 1969
    Posts
    308

    Default RE: Global ASA not working

    Check to see if your directory that contains the global.asa file has been set up as an application. Go to the internet service manager and look at the icon for your directory. If it looks like a regular file folder then it is not set up as an application. To set it up, right click on the folder, select "Properties", then where it says application settings, hit create. That should do it for ya. Let me know if you are still haveing probs.<BR><BR>--brad

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •