Setting up FTP

Results 1 to 2 of 2

Thread: Setting up FTP

  1. #1
    Join Date
    Dec 1969

    Default Setting up FTP

    I am running IIS and have tried to set up an FTP server and was able to hit my server. After reading a book I thought I could change the settings (learning as I go - ha!) and now I am asked to log in before I can hit the site. How do I get rid of the log in issue? I need to upload some files from my laptop to my server and I am not networked.<BR><BR>Thanks!<BR><BR>

  2. #2
    Join Date
    Dec 1969

    Default RE: Setting up FTP

    There are several things that you could have done to make that change:<BR><BR>1. Right click the FTP site in the MMC to choose "properties.<BR>2. Under the security Accounts tab, make sure "Allow Anonymous Connections is checked and the IUSR_accountname and password is entered into the box. I allow IIS to control this password. The default account is usually IUSR_"YourMachinename".<BR>3. Under the Home Directory Tab, make sure that "Read" and "Write" is checked.<BR>4. If your using NTFS Permissions and have messed with them, make sure that the user accound specified in step 2 has write permissions on the files and directories within the ftp folders.<BR><BR>A word of warning: The above setup will allow anyone to upload into the FTP. If you want to secure the site where your the only one allowed to upload/view you have to customize your settings accordingly. Keep in mind there two layers of NT security that apply to this: The IIS settings and the NTFS settings. You have to properly configure both in order to get the FTP secured this way.<BR>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts