Store Procedures

Results 1 to 4 of 4

Thread: Store Procedures

  1. #1
    Dave C Guest

    Default Store Procedures

    &nbsp;<BR>I&#039;m having any problems getting the Navigation Bar Live Object in UD to work with a Stored Procedure?<BR><BR>When we add the Navigation Bar Live Object to the page it<BR>crashes with the following error:<BR><BR>Microsoft OLE DB Provider for SQL Server (0x80040E10)<BR>Procedure &#039;ixWebInventory&#039; expects parameter &#039;@ixSSL&#039;, which was not supplied.<BR>/dave/ixWebInventoryResult.asp, line 158<BR>The section of code that it crashes on is... (Line number 158 is the<BR>MM_rs.Requery statement.)<BR><BR>// reset the cursor to the beginning<BR>if (MM_rs.CursorType &#062; 0) {<BR>if (!MM_rs.BOF) MM_rs.MoveFirst();<BR>} else {<BR>MM_rs.Requery();<BR><BR><BR>We&#039;ve tried using the Move To Server Behaviors to build our recordset<BR>navigation but they generate the same error. It seems like the Requery line<BR>is being called before the recordset has been returned from the Stored<BR>Procedure. (Just a guess.) Adding &#060;% Response.Buffer = True %&#062; to the top<BR>of the page doesn&#039;t help.<BR><BR>We&#039;ve also gone the other route and created the same page but placed the SQL<BR>statement on the page instead of in a Stored Procedure. This actually<BR>worked with the Navigation Bar. However, we would rather use Stored<BR>Procedures for all of our DB searches, etc.<BR><BR>Has anyone experienced a similar problem? Is there something simple that<BR>I&#039;m not doing?<BR>Dave<BR>

  2. #2
    Join Date
    Dec 1969

    Default just curios...

    what is Navigation Bar Live Object ?<BR><BR><BR>it sounds like the SP is looking for a value that is not being passed.

  3. #3
    Dave C Guest

    Default RE: just curios...

    it&#039;s a navigation(move to record). When you only want to display 10 records you have the nav bar on the bottom (<BR><BR><BR>well, when i remove the navigation, all my records shows up, but once i add the navigation, i get that error. i&#039;m not sure if it&#039;s the navigation code that is causing the error. any ideas

  4. #4
    Join Date
    Dec 1969

    Default This may help

    I have not used the component you are using before, but if you would like to try something a little more simple to page your DB query results, check this link out:<BR><BR><BR><BR>If i&#039;m way off, i apologize.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts