Database error??

Results 1 to 4 of 4

Thread: Database error??

  1. #1
    JooTooMan Guest

    Default Database error??

    &nbsp;<BR>I am using an access 2000 database for a message board on my site. Sometimes when you load the page you get this error...........<BR><BR><BR>Microsoft OLE DB Provider for ODBC Drivers error &#039;80040e10&#039; <BR>[Microsoft][ODBC Microsoft Access Driver] Too few parameters. Expected 1. <BR>/messageboard.asp, line 167 <BR><BR>This happens about 75% of the time. The rest of the time it works fine. If you press refresh a few time it also works after the initial error.<BR><BR>Does anyone know what this could be?<BR><BR>Thanks<BR><BR>JooTooMan

  2. #2
    RobT Guest

    Default RE: Database error??

    Something is blank. Have you written out your SQL statements? <BR><BR>response.write SQL<BR><BR>do that before they execute and you will see the name value pairs.<BR><BR><BR>Rob

  3. #3
    Join Date
    Dec 1969

    Default Hmmm

    Without relevant code it&#039;s really hard to debug. Try the FAQ;s for some help with that error.

  4. #4
    Join Date
    Dec 1969

    Default RE: Database error??

    As RobT mentioned, make sure that you&#039;ve got values that correspond to each column name ... also ensure that you&#039;re using the appropriate parentheses. For example:<BR><BR>INSERT INTO the_table (id, aString) VALUES (1, "Here is the string")<BR><BR>This may not work ... Access tends not to like ", and prefers &#039;<BR><BR>... this is better ...<BR>INSERT INTO the_table (id, aString) VALUES (1, &#039;Here is the string&#039;)<BR><BR>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts