ADODB Library not responding to met

Results 1 to 4 of 4

Thread: ADODB Library not responding to met

  1. #1
    dferrell Guest

    Default ADODB Library not responding to met

    Greetings all!!! <BR>I&#039;m getting a weird error message. In fact, it&#039;s not an error message at all! I&#039;ve just installed this machine with win2k, IIS5, with VInterdev 6 and I everytime I execute a simple asp script that used the open method of my recordset to execute a stored proc, the execution just stops and shows me a page that stops mid script with no error message in the source code, popup, nor event viewer. <BR><BR>my code is;s... <BR><BR>DSN = "Provider=SQLOLEDB.1;Persist Security Info=false;UserId = public;Datasource=(deleted for security reasons)" <BR>set rs = server.createobject("ADODB.Recordset") <BR>sSQL = "exec spValidateUser @userid = &#039;test&#039;, @password = &#039;test&#039;" <BR> sSQL, DSN <BR>nUserID = rs("id") <BR>rs.close <BR>set rs = nothing <BR><BR>The code pauses at &#039; sSQL, DSN&#039;. When I step through this with the debugger, when it hits this line it switches the processing to IE5 and shows me an unfinished html page that stops at a &#060;p&#062; tag and no footer html. <BR><BR>I&#039;ve response.write all the paramenters, (ie response.write DSN, or response.write sSQL), but those are being populated just fine. <BR><BR>My current client tells me that they had the same issue when they installed their machines, but when they called Microsoft they found that they had to register a bunch of dlls in order to fix their problem. Unfortunately, they can&#039;t remember what those were. <BR><BR>Does anyone know which DLLS have to be registered in order for the ADODB Library to work correctly with the ISAPI filters? And please don&#039;t just tell me "Register the ADODB, MDAC, ISAPI and ASP dlls again?" as I don&#039;t know the exact names of some of these files. Please give me specifics! Thank you so much in advance for effective solutions you guys may provide. <BR>

  2. #2
    dferrell Guest

    Default RE: ADODB Library not responding to

    For those who may post...I&#039;ve already tried a connection object and an command object and using either the open or command methods of these objects still causes the code to halt. It just doesn&#039;t like ADODB for some strange reason. <BR><BR>I did check the logfiles and found this.... <BR>2001-06-10 22:04:02 x.x.x.x - x.x.x.x 80 GET /images/site/headers/kinte_champagne.gif - 304 141 Mozilla/4.0+(compatible;+MSIE+5.01;+Windows+NT+5.0) SITESERVER=ID=longhexvalue;+ASPSESSIONIDanotherlon ghexvalue <BR>http://localhost/omaxeyo/Login.asp <BR><BR>I&#039;ve tried looking in the microsoft knowledge base for 304 and 141 error codes and got this site about the dataindx.exe file that is a word document. Ironically these two numbers are found in the section about Data Access, but there is no forthcoming information about an error.

  3. #3
    dferrell Guest

    Default RE: ADODB Library not responding to

    I&#039;m sorry let me clarify something. I just tried to type in a DSN. That was not a copy and pasted DSN. I&#039;ve tested the real DSN in Visual Basic and it gets me a connection to a Data Environment DTC. <BR><BR>Code placed here is not exactly the code I use, but an example of what I&#039;m trying to do. Regardless if the code looks kosher, or not it should still at least return an error right? I&#039;m getting nothing for an error.

  4. #4
    dferrell Guest

    Default RE: ADODB Library not responding to

    AAAAHHHHHHHHHH!!!!!!!!<BR><BR>Someone came close and that was the DSN being invalid! You guys know what it was? It was the includes not setting the global constants of DSN. Even though I stepped through the code and the DSNs all were populated, they still were not considered real DSNs by ASP! The moment I declared a local variable within the same subroutine and set it&#039;s value to the ones that the DSNs in the includes had, it worked!!!!<BR><BR>Now I gotta&#039; figure out why the global variables aren&#039;t being really set! AAAAHHHH!!!!!!! Now I can move forward!<BR><BR>Thanks guys!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts