Invalid nonexistent bookmark in Access 97/ASP pgm?

Results 1 to 2 of 2

Thread: Invalid nonexistent bookmark in Access 97/ASP pgm?

  1. #1
    elaine pack Guest

    Default Invalid nonexistent bookmark in Access 97/ASP pgm?

    We have a set of ASP programs that create and edit job application records. The underlying database is Access 97, and it consists of a "master table" ("page1") with relationships to several other subsidiary tables (page2, page3, etc). On a brand new application, the logic flow is <BR><BR>1. User enters a social security number into a "menu" page. <BR>2. The SSN is passed into applpage1.asp where the first page of the application is set up. (If it is already on the database, the record&#039;s contents would be displayed on this page) A blank form displays. The passed in SSN displays at the top of the page, but otherwise is not edited. The user fills in fields as necessary and hits submit.<BR>3. Control passes to postpage1.asp which saves (or updates if an existing rec) the fields from applpage1, then automatically goes to applpage2.asp with the record key from the page1 record it just created (which is a related link to the other tables)<BR>4. Applpage2 first selects a recordset from Page1 (for editing purposes for other tables to be created), then when the user submits THIS page, it goes to postpage2.asp where the next table is created, and so on thru 6 pages.<BR><BR>The problem is that the _very first time_ a new record is created, we create the Page1 record just fine in postpage1, but when it goes into applpage2, it breaks on the execute sql line shown below. There are NO bookmarks set on the Access file, so this error is a mystery to me. A coworker suggested it might be a timing issue, ie, the page1 record isn&#039;t quite created before applpage2 is referencing it, but I don&#039;t know if that&#039;s true, or even a valid scenario. If we immediately go back in again with the same SSN, everything works fine and the page2 rec gets created with no problems.<BR><BR>Can anyone suggest anything?? <BR><BR>Thanks!<BR>elaine pack<BR><BR>set cnPage2=Server.CreateObject("ADODB.Connection")<BR >cnPage2.Open("DSN=ApplHold")<BR>mySQL = "SELECT ID, NameFirst, NameMiddle, NameLast, SSN "<BR>mySQL = mySQL &"FROM page1 "<BR>mySQL = mySQL &"WHERE ID = " &PassedinID &";"<BR>set rsPage1=cnPage2.execute(MySQL) --&#062; line it breaks on<BR><BR>Microsoft OLE DB Provider for ODBC Drivers error &#039;80004005&#039; <BR>[Microsoft][ODBC Microsoft Access 97 Driver] Not a valid bookmark. <BR>/appl/applpage2.asp, line 33 <BR>

  2. #2
    Join Date
    Dec 1969

    Default RE: Invalid nonexistent bookmark in Access 97/ASP

    We are having the exact same problem.<BR>Tried setting some permissions, but that doesnt seem to work.<BR>Reloaded access 97, that didnt help.<BR>Please let me know if you recieve any other helpful advice about this problem, i would like to work together to solve our common are not alone!!<BR>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts