please help w/ server.urlencode!!

Results 1 to 4 of 4

Thread: please help w/ server.urlencode!!

  1. #1
    L Guest

    Default please help w/ server.urlencode!!

    I&#039;m trying to pass the image path and display the image in the popup window. This code works fine in netscape but doens&#039;t work in IE. For ex. in IE the image path is under a subfolder A/A1234.gif but it displays as AA1234.gif (skips the slash). Can someone help me on this? Thanks in advance! <BR>&#060;a href="javascript:win(&#039;;%=Server.UrlEncode(rs("image-path"))%&#062;&#039;)"&#062;&#060;img src=";%=rs("image-path")%&#062;" height=120 width=200 border=0&#062;&#060;/a&#062;

  2. #2
    Divinite Guest

    Default RE: please help w/ server.urlencode!!

    The problem you&#039;re facing there is that when you encode a "/" using Server.URLEncode the server then tries to change that character (such as it changes a space to %20). Try it without the encode.

  3. #3
    L Guest

    Default RE: please help w/ server.urlencode!!

    When not using Server.URLEncode the imagepath doesn&#039;t working in both netscape nor IE! When I use it, it works only in netscape!<BR>

  4. #4
    Divinite Guest

    Default RE: please help w/ server.urlencode!!

    Are you using Server.HTMLEncode within your document when calling the image? This might also help it to show up.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts