Results 1 to 2 of 2

Thread: HEEEELP!!!!!!

  1. #1
    The SpEyE Guest

    Default HEEEELP!!!!!!

    I need some heeelp!!!!<BR><BR>I&#039;m new to ASP, and I&#039;m having a few problems with my databases.<BR><BR>I&#039;ve uploaded all my DB&#039;s to my DB folder, and changed all of the code in my page so that everything should work, however, since I&#039;ve tried to add more than one table into the database, the entire thing has gone wrong.<BR><BR>When I now go to the site, it keeps telling me that I can&#039;t view the database and I get the following error:<BR><BR>Active Server Pages error &#039;&#039; <BR><BR>[Microsoft][ODBC Microsoft Access Driver] Cannot open database &#039;(unknown)&#039;. It may not be a database that your application recognizes, or the file may be corrupt. <BR><BR>/the-lab/main/index.asp, line 158 <BR><BR><BR>This has only started since I tried to add another table to the DB, but the code which links the DB to the ASP file, is the same.<BR>My webpage is located at &#060;a href="www.planethalflife.com/the-lab"&#062;www.planethalflife.com/the-lab&#060;/a&#062;.<BR><BR>I don&#039;t know what the problem could be, and I was hoping someone here could give me a hand.<BR><BR>Thanks<BR>The SpEyE<BR><BR>Oh yeah, and if anyone wants to look at my code, its at &#060;a href="www.planethalflife.com/the-lab/the-lab.zip"&#062;www.planethalflife.com/the-lab/the-lab.zip<BR>&#060;/a&#062;<BR>

  2. #2
    Join Date
    Dec 1969

    Default change your DB connection...

    try changing your db connection...<BR>from:<BR>MyConn = "Driver={Microsoft Access Driver (*.mdb)}; DBQ=//netapp1/www/planethalflife/the-lab/db/the-lab.mdb;"<BR><BR>to<BR><BR>MyConn = "Driver={Microsoft Access Driver (*.mdb)}; DBQ=" & server.mappath("../db/the-lab.mdb") & ";"<BR><BR>Then try it with the virtual path, looks like the server is havin probs findin the database.<BR>-- Whol

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts