Problems with adding a new record to a database.

Results 1 to 2 of 2

Thread: Problems with adding a new record to a database.

  1. #1
    Latreece Guest

    Default Problems with adding a new record to a database.

    I put this on the ASP board first, but maybe I&#039;ll get an answer to part of my question in this forum...<BR><BR>I am trying to add a new record to a database (Access) using Javascript. I have more than 25 fields to add. Of course, having that many fields in an Execute statement doesn&#039;t work. It works fine if I cut down the number of fields, but I need all 26 fields. I tried to change the Javascript to VBScript so that I could just do an "AddNew" thing and not be limited to the number of fields. When I tried that, I get an error saying that one of my objects is missing (Microsoft VBScript runtime error &#039;800a01a8&#039; Object required: &#039;Shipping&#039;). The object that it is referring to is actually there, but the object is defined in a javascript server-side command. It&#039;s kind of weird because eventhough I get an error, the function that refers to the object returns the correct answer (which it could not do if the object were actually not found). So, I need to know either how to add a record using JavaScript without having a limit on how many fields I can use or I need to know how to eliminate the VBScript runtime error. This is the only thing keeping me from making my site go live. Please Help! Thanks!!!!!

  2. #2
    Join Date
    Dec 1969
    Los Angeles, CA

    Default Always post RELAVENT code in the world will we know your error and cause unless you post your code and the error message...we are NOT mindreaders here and do not have crystal balls to look at your code.<BR><BR><BR>having said that lose the .addnew and use the insert your SQL statement

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts