SELECT permission denied

Results 1 to 3 of 3

Thread: SELECT permission denied

  1. #1
    Join Date
    Dec 1969

    Default SELECT permission denied

    I keep on receiving this error when I try and request information from our SQL database:<BR><BR>Microsoft OLE DB Provider for ODBC Drivers error &#039 80040e09&#039 <BR><BR>[Microsoft][ODBC SQL Server Driver][SQL Server]SELECT permission denied on object &#039Categories&#039, database &#039lifestylesa2z_master&#039, owner &#039dbo&#039. <BR><BR>I have even tried a simple request:<BR><BR>&#039connection and recordset object has already been established before this of course<BR><BR>Dim strSQL<BR>strSQL = "SELECT CategoryName FROM Categories ORDER BY CategoryName"<BR><BR>Response.Write strSQL <BR>&#039this was to see where the error originates from<BR><BR>objRec.Open strSQL, objConn <BR>&#039when it hits this line of code I receive the error<BR><BR>Response.Write strSQL <BR>&#039doesn&#039t reach this line<BR><BR>Is this a problem with the asp code or how the SQL Database is set up?<BR><BR>The code was tested with a Microsoft Acess database before they set up the SQL database. It worked fine. Once the SQL one was done, the System DSN was changed to point to the SQL database. Would any thing else have to be changed? <BR><BR>Any help would be appreciated. Thanks

  2. #2
    Join Date
    Dec 1969

    Default RE: SELECT permission denied

    &#039permission denied&#039 means that this particular user does not have permission to perform (in this case) select on this one particular table.<BR>Check your table permission for this user.<BR>

  3. #3
    kreddy Guest

    Default RE: SELECT permission denied

    Hay tammerlee,<BR> Just u need to go to the Access database and double clik the table object("categories").Here click on the Tools on the Menu bar and there u can see the security, when u go to the security u get a submenu where u can see userandgroup permissions there u will find the permissions icon when u choose that it will popup a list of options this is the place wher u can select the permissions if it is not checked just make sure and check the mark adjacent to the check box<BR><BR>hope this serves the problem

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts