I'm getting mad - ACCESS 97

Results 1 to 3 of 3

Thread: I'm getting mad - ACCESS 97

  1. #1
    Gino Guest

    Default I'm getting mad - ACCESS 97

    Hello!<BR><BR>It was supposed to be so simple, but well, i&#039;m trying now for hours...<BR><BR>I want to do this on MS ACCESS 97 "DB":<BR><BR>UPDATE mytable SET col1=col1+1;<BR><BR>You see, just a simple counter...Bit it doesn&#039;t work! Im getting strange results, eg col1 is 5 then a run the update -&#062; col1 is 0. col1 is 5 then I run the update but with +50 -&#062; col1 is 49.<BR><BR>Does anyone know what I didn&#039;t thought at? It must be a very stupid thing. I first thought, perhaps a commit is missing, but that wasnt&#039; the problem. By the way I tried this SQL-satement an an ORACLE and it worked fine. ANd yes: I tried via ASP and directly on the &#039;desktop version&#039; of MS ACCESS --&#062; same result.<BR><BR>Please if anyone have any idea...<BR><BR>Thanks in advance<BR>Gino

  2. #2
    Join Date
    Dec 1969

    Default RE: I'm getting mad - ACCESS 97

    looks fine to me --- have you tried<BR>UPDATE mytable SET mytable.col1=mytable.col1+1;<BR>and you have got an exisitng record in this table?! ( just checking ) <BR>hmmmmmmm .....

  3. #3
    Join Date
    Dec 1969

    Default What is data type of the field?

    In the schema, what data type is "col1"???<BR><BR>Incidentally, you aren&#039;t specifying any record in the UPDATE, so the col1 value of *EVERY RECORD* in the table should be changed. Is that happening?<BR><BR>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts