"SQL Type number "mediumint" is not in map" error

Results 1 to 2 of 2

Thread: "SQL Type number "mediumint" is not in map" error

  1. #1
    Mark Guest

    Default "SQL Type number "mediumint" is not in map" error

    Hi Guru&#039;s - I´m using Ultradev & PowerClimb Cart extension & I just switched to a Mysql database & a Linux box from Access database on an NT machine. Having solved various other anomalies I&#039;m stuck with this one. When trying to load the confirm order page the server hangs.<BR><BR>Double clicking on the "Add Cart To Table" server behaviour on the confirm order page now brings up this warning "SQL Type number "mediumint" is not in map" Having checked everything else I can think of I believe this must be the cause of the problem & why the confirm order page now not loading.<BR><BR>All was fine when I was using Access & NT the cart worked perfectly. Being Very new to asp/sql I would appreciate some explain on what this means & how to cure the "SQL Type number "mediumint" is not in map" error<BR>Many thanks.<BR><BR>

  2. #2
    Join Date
    Dec 1969

    Default The old crystal ball...

    ...can&#039;t seem to see your source code. In particular, the source that is producing this error.<BR><BR>JUST AS A GUESS... I&#039;d bet that Ultradev thinks there ought to be three sizes of integer (whether 8, 16, and 32 bit or 16, 32, and 64, I dunno). And MySQL only supports two sizes (probably 16 and 32). Probably, some of the SQL being generated relies on using a type of "mediumint" (though I can&#039;t imagine why...maybe it tries to do a "cast" to that type?). So find where that is happening and just use "int" or "integer" (whichever MySQL supports) instead.<BR><BR>When you use a tool like Ultradev, you are losing a lot of control, so it&#039;s often hard to customize it for a particular configuration.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts