ASP not working

Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: ASP not working

  1. #1
    Join Date
    Dec 1969
    Posts
    109

    Default ASP not working

    Hi there,<BR><BR>Twice now over the past two weeks we&#039ve experienced a problem where all the ASPs on our server stop working. A reboot of the server clears up the problem. I&#039d like to know if anyone has an idea as to why this is happening. Sorry for lack of details, I haven&#039t noticed anything in common between the two incidents.<BR><BR><BR>Oliver

  2. #2
    Join Date
    Dec 1969
    Posts
    1,324

    Default RE: ASP not working

    What do you mean, stopped working? Would the "download" box in the browser come up, would the ASP show as HTML, would you get errors when viewing the pages through the browser?

  3. #3
    Join Date
    Dec 1969
    Posts
    109

    Default RE: ASP not working

    Sorry, I know how vagueness can be annoying. ;)<BR><BR>Basically, the page "hangs", the little globe spins or the little comets fly, and after about two minutes the browser returns a "could not load the page" error.<BR><BR>This happened twice within the past 2-3 weeks and I can&#039t think of anything that precipitated the problem. I&#039m wondering if anyone else has seen this before and if they were able to pinpoint the cause.<BR><BR><BR>Oliver

  4. #4
    John Martin Guest

    Default RE: ASP not working

    I&#039ve had this problem with IIS 3.0 on our server in London, and also with IIS 4.0 on servers at web host firm 9NETAVE.NET. HTML pages will serve fine, but all pages ending with .asp fail with a time-out.<BR><BR>Looks like the asp service itself is halted or in a loop somewhere.<BR><BR>On the IIS 3.0 server, it was caused (at least some of the time) by a failed Oracle connection. Seems that the database access through IIS 3.0 wasn&#039t threaded right. When we killed the Oracle process on the database server, the IIS server started working again. Go figure.<BR><BR>Booting the NT server will fix the problem no matter what. Did you try stopping and restarting the IIS service?<BR><BR>


  5. #5
    Join Date
    Dec 1969
    Posts
    109

    Default RE: ASP not working

    >Booting the NT server will fix the problem no matter what. Did >you try stopping and restarting the IIS service?<BR><BR>Yep, we figured out that stopping and starting IIS fixes it too. A lot better than a reboot! Might be a db connection issue. We updated our mdac drives yesterday to fix another weird problem so maybe that will help out with this one too.<BR><BR>Thanks.<BR><BR><BR>Oliver<BR><BR>

  6. #6
    Kudeck Guest

    Default RE: ASP not working

    Can you provide a URL for the site experiencing the problem?<BR><BR>I&#039ve got a theory I would like to test...

  7. #7
    PJ Guest

    Default RE: ASP not working

    I believe you have (what I like to refer to as) a "looper." You could have some sort of WHILE loop that isn&#039t ever false, and it is sucking the life out of the ASP engine. What is the CPU usage like when you reach this locked-up condition?<BR><BR>Also, when you say reboot, do you mean:<BR>1) net stop w3svc,<BR>2) kill inetinfo.exe<BR>OR<BR>3) Start, Shutdown, Restart the junky, ole&#039 server?

  8. #8
    Daniel Root Guest

    Default RE: ASP not working

    I Had that problem when my ODBC drivers were somehow not all the same version. The whole server would lock up (I couldn&#039t merely stop and restart the services, I had to completely reboot) To fix, I waded through microsoft&#039s download pages until I found the newest ODBC drivers.<BR><BR>-D

  9. #9
    Michael Lebron Guest

    Default RE: ASP not working

    I have heard of this problem before and had it in the past. Whats funny is that it comes at weeks at a time or minutes at a time. I spoke with someone who was having this problem also; they broke down and actually called MS. They were told that this is a known problem and may be a hot fix for SP 5. Its a fix for IIS that of course you are charged for. You need NT Server support to obtain the fix and they claim that it has not been fully tested and only recommend installing it if you are having this hanging problem. I would recommend contanting them if you have support and try this fix. If I can I will try to get an update on how the fix worked and post it here.

  10. #10
    Michael Lebron Guest

    Default RE: ASP not working

    I have heard of this problem before and had it in the past. Whats funny is that it comes at weeks at a time or minutes at a time. I spoke with someone who was having this problem also; they broke down and actually called MS. They were told that this is a known problem and may be a hot fix for SP 5. Its a fix for IIS that of course you are charged for. You need NT Server support to obtain the fix and they claim that it has not been fully tested and only recommend installing it if you are having this hanging problem. I would recommend contanting them if you have support and try this fix. If I can I will try to get an update on how the fix worked and post it here.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •