No read permissions on Access database?

Results 1 to 2 of 2

Thread: No read permissions on Access database?

  1. #1
    Dave Shacket Guest

    Default No read permissions on Access database?

    I have tried to connect my ASP page to an Access database and it tells me I have no read permissions on it. I have removed ALL permissions to test it out and still get that message.<BR><BR>I am using PWS on Windows 98. Any suggestions? My code follows (I have commented a lot of lines because I tried connecting a number of different ways - they all ended up with the same error)<BR><BR>Dave Shacket<BR><BR>**********CODE START*************<BR>&#060;HTML&#062;<BR>&#060;BO DY&#062;<BR>&#060;B&#062;Welcome to my page hosted on PWS!&#060;/B&#062;<BR><BR>The time is now: &#060;%=TIME%&#062;<BR><BR><BR>&#060;%<BR>Dim conn, db, rs<BR>&#039;Set db = Server.CreateObject("ADODB.Connection")<BR>&#039;d b.Open "Provider=Microsoft.Jet.OLEDB.4.0; Data Source=" & Server.MapPath("webdatabase.mdb") & ";","",""<BR>&#039;Set rs = db.execute("Select * FROM qryPowerLeaders")<BR><BR>&#039;strConn = "DRIVER={Microsoft Access Driver (*.mdb)};DBQ=" & Server.MapPath("webdatabase.mdb")<BR>set conn = server.createobject("adodb.connection")<BR>conn.op en "webdatabase", "Web", "ASP"<BR><BR><BR>set rs = server.createobject("adodb.recordset")<BR>strSql = "Select * FROM qryPowerLeaders"<BR>set rs=conn.execute(strSql)<BR><BR>If Not rs.EOF Then rs.MoveFirst<BR>Do While Not rs.EOF<BR>Response.Write NameLF & "<BR>"<BR>rs.MoveNext<BR>Loop<BR><BR>rs.Close<BR>S et rs = Nothing<BR><BR>%&#062;<BR><BR>&#060;/BODY&#062;<BR>&#060;/HTML&#062;<BR>

  2. #2
    Jeremy #121 Guest

    Default RE: Locked the DB Threw away the key..

    Hey-<BR><BR>Did you actually try to take the DB into MSAccess and go to Tools&#062;Security and remove any permissions. Also take the file into explorer and right-mouse-click&#062;Properties&#062; uncheck Read Only.<BR><BR>If none of these work then I suggest making a new DB and importing all the old stuff. It sounds though that the asp script is trying to open it, but Access wont allow it to open.<BR><BR>Jeremy #121

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts