This is a strange one. I have code and an access database that&#039;s worked fine for days on the server, with the right permissions, whatever. Then today it gives the "Operation must use an updateable query" error.<BR><BR>Anyway, I verified everything with:<BR> <BR><BR>I didn&#039;t change any code or server settings, just re-uploaded a copy of the database I had local and everything worked fine again.<BR><BR>This concerns me as I won&#039;t always have a current copy running locally. Why did this error just suddenly happen? Was the database corrupt or something if copying over a new one worked fine with the same code, permissions, etc?<BR>