rs.addnew makes MEMO field problems

Results 1 to 2 of 2

Thread: rs.addnew makes MEMO field problems

  1. #1
    Martin Siefert Guest

    Default rs.addnew makes MEMO field problems

    To all ASP Gurus out there.<BR><BR>I have a problem with my ASP code and my Access 2000 database.<BR>I try to use the rs.AddNew function with the rs.Update function to insert a recordset into the database. Everything gets inserted successfully besides a field called "Description". This field is a MEMO field and is not filled in in the database.<BR>If I change the "Description" field type to "Text" it works. As soon as I change it back to "Memo" - no content gets entered in the database.<BR><BR>Please let me know what the heck is going on? I tried to wrap the Description values around quotes (") (&#039;), didn&#039;t help.<BR><BR>Where is my mistake?<BR><BR>Please help.<BR><BR>Thanks<BR><BR>Martin<BR><BR>Here is the code:<BR><BR>Dim sql<BR>SET rs = Server.CreateObject("ADODB.Recordset")<BR>sql = "Select * From TestRun WHERE ID=-1"<BR>rs.LockType = 3<BR>rs.Open sql, "testdb", 3<BR>rs.addnew<BR>rs.MoveLast<BR><BR>&#039; make recordset available for access after writing data<BR>&#039;ID is assigned automatically by DB<BR>rs("Date") = date()<BR>rs("FirstName")=request.form("FName")<BR >rs("LastName")=request.form("LName")<BR>rs("Descr iption")=request.form("description")<BR>rs.Update

  2. #2 Guest

    Default Look at ASPFAQ

    Suggest you check out this link to the FAQ:<BR><BR>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts