The script works great on my PWS, but When I try to run it on the server I get a runtime error:<BR>************<BR>Microsoft VBScript runtime error &#039;800a005b&#039; <BR><BR>Object variable not set <BR><BR>/admin/newspreview.asp, line 89<BR>***********<BR>basically the needed part is below:<BR>*********** <BR>Dim objConn, objRS, strAdminEmail, bFound<BR>Set objConn = Server.CreateObject("ADODB.Connection")<BR>objConn .ConnectionString = "DSN=data.dsn"<BR>objConn.Open<BR>Set objRS = Server.CreateObject("ADODB.RecordSet")<BR>objRS.Op en "totalsubmitters", objConn, adOpenForwardOnly, adLockOptimistic, adCmdTable <BR>Do while not objRS.EOF<BR> <BR> If (StrComp(Trim(objRS("adminname")), Trim(Request.Form("selectadmin")), VbTextCompare) = 0) Then<BR> If not (strComp(Trim(objRS("adminpass")), Trim(Request.Form("adminpass")), VbTextCompare) = 0) Then<BR> objRS.Close<BR> Set objRS = Nothing<BR> objConn.Close<BR> Set objConn = Nothing <BR> Response.Write("Sorry, password is wrong! press the back button to change the infos..<BR><BR>&#060;input type=&#039;submit&#039; name=&#039;Submit&#039; value=&#039;change info &#039; onClick=&#039;history.go(-1); return false;&#039;&#062;<BR><BR><BR><BR><BR><BR><BR><BR> ")<BR> Response.End<BR> Else<BR> strAdminEmail = objRS("adminmail")<BR> bfound = true<BR> End If<BR> End If<BR>objRS.MoveNext<BR>Loop<BR>objRS.Close<BR>*** *********************<BR>The line 89 is : strAdminEmail = objRS("adminmail")<BR><BR><BR>Any idea? I am really getting frustrated, because some of my scripts run perfectly on PWS and not on my server. The host is Tera-Byte by the way. Any issues about them? maybe VBScript version?<BR><BR>