Win2K, IIS 5 and NO ASP

Results 1 to 3 of 3

Thread: Win2K, IIS 5 and NO ASP

  1. #1
    mook Guest

    Default Win2K, IIS 5 and NO ASP

    I&#039;ve scoured these boards and there are many with the same problem - but no resoultion???<BR><BR>I recently insalled IIS 5 on Win 2K Professional, and no ASP pages can be viewed (not even the Microsoft help files, so its not a code issue). Execute permissions are set to Scripts Only, and Read permisions are set (and i&#039;ve tried every other combination). HTML files view fine its just ASP pages. The event log reports the following WARNING...<BR>The server failed to load application &#039;/LM/W3SVC/1/Root&#039;. The error was &#039;c000003b&#039;. <BR><BR>and the following ERROR ...<BR>The COM Application &#039;{3D14228D-FBE1-11d0-995D-00C04FD919C1}&#039; at &#039;/LM/W3SVC/1/Root&#039; failed to activate out of process. <BR><BR>the Microsoft KB is no help???<BR><BR>What is going on??? Surely someone knows.<BR><BR>Thanks Marcus<BR><BR>

  2. #2
    Gary Muzny Guest

    Default RE: Win2K, IIS 5 and NO ASP

    Marcus, did you ever figure this out.<BR>I&#039;ve got the exact same problem!!<BR>

  3. #3
    mook Guest

    Default RE: Win2K, IIS 5 and NO ASP

    No still haven&#039;t figured it out, I did find some info that seemed to suggest it might be a problem caused by a Crystal Reports 8 installation which messes around with ODBC registry permissions, see but I ran the patch (after uninstalling CR) and it didn&#039;t work for me.<BR><BR>The only other advice I&#039;ve seen is to use regmon and root out the individual registry keys like this, had the same problem on a new install of WIN2KPRO. I ran the Regmon utility from while accessing the asp pages. It showed several registry keys that denied access for an openkey request. Edited the keys with regedt32.exe and added permissions for "everyone" and it solved the problem. When loading the asp page, the server errors out on the first key, so you have to reload the page after fixing a key to see the next one that denies access. I&#039;ve seen posts that this is related to installing Crystal Reports v8.<BR>- Anonymous 23 Jan 2001.<BR><BR>but i don&#039;t feel confident hacking about the registry. Let me know if you&#039;ve managed to shed any light on this. There seems to be a number of people having difficulties with this.<BR><BR>Marcus<BR><BR>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts