Help with errors in accessing a database

Results 1 to 4 of 4

Thread: Help with errors in accessing a database

  1. #1
    Join Date
    Dec 1969
    Posts
    1,912

    Default Help with errors in accessing a database

    I&#039ve recently been working on a project for an employee database and everything&#039s been running smoothly until we moved the files from my computer to the real server. When I try to UPDATE and INSERT new records to the database i get this error:<BR><BR>Microsoft OLE DB Provider for ODBC Drivers error &#039 80004005&#039<BR><BR>[Microsoft][ODBC Microsoft Access Driver] Operation must use an updateable query.<BR>-------------------------<BR><BR>When I try to DELETE from the database I get this error:<BR><BR>Database Errors Occured:<BR>DELETE * FROM EMPINFO where ID=109744<BR><BR>Error #-2147467259<BR><BR>Error desc. -> [Microsoft][ODBC Microsoft Access Driver] Could not delete from the specified tables.<BR>---------------<BR><BR>I&#039m guessing this has something to do with the way things are set up on the server since everything worked when the files were on my computer. If anyone has any clue why I&#039m getting these errors, please let me know! Thanks :)<BR><BR>Dave

  2. #2
    Ben Jones Guest

    Default RE: Help with errors in accessing a database

    I can&#039t comment on the update / insert code, but your delete error is caused by the wildcard symbol in the SQL. The proper syntax for deleting is:<BR><BR>DELETE FROM [table_name] WHERE [field] = [value]

  3. #3
    Join Date
    Dec 1969
    Posts
    1,912

    Default Displaying the Field names in a database

    I was wondering how in ASP, if you open a table from a database, can you display all the FIELD names... I don&#039t want the information in the fields, just the names of the fields.. I have a need to keep an updated list of the names of all the fields in the database, and this would be very useful. Thanks

  4. #4
    Join Date
    Dec 1969
    Posts
    30

    Default RE: Help with errors in accessing a database

    It has something to do with the permissions settings of your virtual directory in which you are running all your ASP files and database too. <BR><BR>You would have to reset this permissions. Try it out.<BR><BR>Good Luck,


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •