IIS reports 405 - resource not allowed

Results 1 to 2 of 2

Thread: IIS reports 405 - resource not allowed

  1. #1
    Rob Guest

    Default IIS reports 405 - resource not allowed

    Good afternoon,<BR><BR>I am trying to upload a file to an upload directory from a browser but fail with a 405 error in IE. The address of the page is:<BR>http://h004f49086f4a.ne.mediaone.net/oldsads/uploadtest2.asp<BR><BR>I read up on these articles to get a feel for how to accomplish this:<BR>http://msdn.microsoft.com/workshop/server/asp/server052499.asp<BR>and <BR>http://support.microsoft.com/support/kb/articles/Q266/4/52.ASP?LN=EN-US&SD=gn&FR=0&qry=file%20upload&rnk=1&src=DHCS_MSP SS_gn_SRCH&SPR=VID<BR><BR>"My error is HTTP 405 - Resource not allowed<BR>Internet Information Services"<BR><BR>I used the advice of the below article:<BR>http://support.microsoft.com/support/kb/articles/Q247/5/36.asp <BR><BR>and modified my action= parameter to what you see here:<BR>http://h004f49086f4a.ne.mediaone.net/oldsads/uploadtest2v2.txt<BR>And I get the same error even directly referencing the post address.<BR><BR>The source of the uploadfile asp can be seen by viewing source of:<BR>http://h004f49086f4a.ne.mediaone.net/oldsads/uploadtest2.txt<BR><BR>I have set up permissions to allow the IUSER_Machine name account to write to the imageupload subdirectory, and made sure in IIS that write access is allowed, and no authentication methods are selected and anonymous access is checked. Also I made sure the scripts folder and the cpshost.dll file has permissions for the IUSR_Machine acct to read it.<BR><BR>The string for posting should be fine and it is reported on the page as being"<BR>strPostingURL = http://h004f49086f4a.ne.mediaone.net/Scripts/cpshost.dll?PUBLISH?http://h004f49086f4a.ne.mediaone.net/oldsads/SendMail2.asp <BR><BR>And that should be fine. <BR><BR>You can see the source of the SendMail2.asp by viewing source here:<BR>http://h004f49086f4a.ne.mediaone.net/oldsads/SendMail2.txt<BR><BR>If you just click send with no attachment it works fine and sends an email with no attachment and no file is uploaded to the server imageupload directory. I only have problems when a file is attached.<BR><BR>Any suggestions?<BR>Thanks!<BR>Rob

  2. #2
    Join Date
    Dec 1969

    Default RE: IIS reports 405 - resource not allowed

    Something&#039;s not configured correctly. If I go to any of your links I get prompted for an UserName/pwd/domain i.e. your server is prompting me to log in via NTLM.<BR><BR>So, you still have a permissions issue my hunch is that it&#039;s related to file/directory permissions.<BR><BR>One of your links gave me error:<BR>(note the: HTTP 401.3 - Access denied by ACL on resource")<BR><BR><BR>You are not authorized to view this page <BR>You do not have permission to view this directory or page using the credentials you supplied. <BR><BR>--------------------------------------------------------------------------------<BR><BR>Please try the following:<BR><BR>Click the Refresh button to try again with different credentials. <BR>If you believe you should be able to view this directory or page, please contact the Web site administrator by using the e-mail address or phone number listed on the h004f49086f4a.ne.mediaone.net home page. <BR>HTTP 401.3 - Access denied by ACL on resource<BR>Internet Information Services<BR><BR>--------------------------------------------------------------------------------<BR><BR>Technical Information (for support personnel)<BR><BR>More information:<BR>Microsoft Support <BR> <BR>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts