Typelib not found error

Results 1 to 2 of 2

Thread: Typelib not found error

  1. #1
    Barry Guest

    Default Typelib not found error

    After I reinstalled MDAC I dereferenced the type libraries in the Project References and then rereferenced them after saving the Global.asa without any references.<BR> Even after re-installing ADO 2.5 on my dev machine and on the server, I still get the following error on my web page: <BR><BR>&#039;********************************** * <BR>Active Server Pages error &#039;ASP 0223&#039; <BR><BR>TypeLib Not Found <BR><BR>/hats_Dev/global.asa, line 5 <BR><BR>METADATA tag contains a Type Library specification that does not match any Registry entry. <BR>&#039;**************************************** ** <BR>Any clues how to fix this? Without doing away with my ADO calls. <BR><BR><BR>Here&#039;s the 1st 6 lines, it is put in automatically when I set the project references: <BR><BR>&#060;!--==Visual InterDev Generated - startspan==--&#062; <BR>&#060;!--METADATA TYPE="TypeLib" NAME="Microsoft ADO Ext. 2.5 for DDL and Security" UUID="{00000600-0000-0010-8000-00AA006D2EA4}" VERSION="2.5"--&#062; <BR>&#060;!--METADATA TYPE="TypeLib" NAME="Microsoft ActiveX Data Objects (Multi-dimensional) 2.5 Library" UUID="{22813728-8BD3-11D0-B4EF-00A0C9138CA4}" VERSION="2.5"--&#062; <BR>&#060;!--METADATA TYPE="TypeLib" NAME="Microsoft ActiveX Data Objects Recordset 2.5 Library" UUID="{00000300-0000-0010-8000-00AA006D2EA4}" VERSION="2.5"--&#062; <BR>&#060;!--METADATA TYPE="TypeLib" NAME="Microsoft ActiveX Data Objects 2.5 Library" UUID="{00000205-0000-0010-8000-00AA006D2EA4}" VERSION="2.5"--&#062; <BR>&#060;!--==Visual InterDev Generated - endspan==--&#062; <BR><BR>

  2. #2
    Join Date
    Dec 1969

    Default RE: Typelib not found error

    Why are you adding references to ADO objects? You shouldn&#039;t have to do this. Just eliminate the danged things, you should have no problem.<BR><BR>The only article I found suggests that the COM objects weren&#039;t registered correctly, and as such, you should re-install:<BR><BR>http://msdn.microsoft.com/library/psdk/iisref/glob4b5f.htm<BR><BR><BR>Now, I&#039;m using ADO, and my global.asa has none of these declarations.<BR><BR>Also (from that article):<BR>"It is very common for a COM component to describe any constants that it supports in a type library. If your Web application relies on COM objects that have declared data types in type libraries, you can declare the type libraries in Global.asa. Doing so will make it possible to refer to the constants declared in the type libraries from any script within the application boundary."<BR><BR>I don&#039;t think this is the case with ADO. Otherwise, why would you need "adovb.inc?"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts