databases in access me no like

Results 1 to 2 of 2

Thread: databases in access me no like

  1. #1
    Join Date
    Dec 1969

    Default databases in access me no like

    hey i know some of yall are prolly sick of me but this is one of the few places i have to try to find answers. i was asking a bunch of questions yesterday..derek you were answering them so if you happen to be there today, i would love your help... i am having database issues. i posted a reply yesterday evening but i haven&#039t got an answer so i&#039m gonna try reposting it right here. a broad summary: i am trying to input info into a database and it&#039s giving me a "can&#039t write to an unupdatable query" error. i&#039ve changed the permissions in the database, i&#039ve tried a dsn-less conneciton, oledb conneciton. the prob is, it works fine from the server on my computer, but when i try to run it from this other server, i get that error. i don&#039t know what could have changed between here and there. here are the last messages from yesterday. if anyone has any ideas, I would love to hear them<BR><BR>derek wrote:<BR> Chrissy, this isn&#039t a problem with Access (you really shouldn&#039t have had to install it at all); it&#039s a problem with the server&#039s setup. Are you sure ADO is installed? If so, what version? I&#039d stick with the oledb connection if I were you (it&#039s much faster). I&#039ve lost track of your open statement for the recordset - are you using a static or keyset cursor (3 and 1, respectively). What about the lock type - make sure it&#039s adlockoptimistic (3)? <BR><BR>I WROTE:<BR>ok i dont&#039 know what you are talking about when you say "lock type" and "key set" sorry, like i said, i am just now learning all this stuff. i have tried using an oledb connection and it will work on my server but i get the same exact error on the other server. <BR><BR>how can i find out for sure if ADO is installed? i have a file caleld ado under c;&#062;program files&#062;common files&#062;system.....but i don&#039t know what to look for. <BR><BR>ok btw, derek i really appreciate all your help. i hope i&#039m not frusturating you too much. but i&#039m shootin in the dark here and no one in my office knows asp and very few know much about databases. so ,..thanks. <BR><BR>i also tried putting in : con.mode=3 but that didn&#039t do anythign either. <BR><BR>oh one more thing that i also found very odd. when i first tested all of this, the very first worked. then i starrted getting these error messages. so then i went to my output page and I am able to view all the records from the database. on this page i have put the option to delete a row. The first time i tried to do it, it worked fine. the second time worked fine. the third time however i got the same error message as before. and now that&#039s all i get. i think that&#039s very odd.... <BR><BR><BR>PHEW! very long... sorry guys...

  2. #2
    Join Date
    Dec 1969
    Los Angeles, CA

    Default Lets try and make it short

    Post your code. the bit where you are updating and the error message

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts