Connect Error - Permission settings??

Results 1 to 2 of 2

Thread: Connect Error - Permission settings??

  1. #1
    Join Date
    Dec 1969

    Default Connect Error - Permission settings??

    Hi,<BR><BR>I&#039m trying to connect to an Access2000 database to add records (from an ASP page), and I am getting the following error message:<BR><BR>Microsoft JET Database Engine error &#039 80004005&#039 <BR><BR>The Microsoft Jet database engine cannot open the file &#039...db1.mdb&#039. It is already opened exclusively by another user, or you need permission to view its data. <BR><BR>/james/default.asp, line 15 <BR><BR>I think the connection code itself is correct (by the way, thanks Pete for helping with my earlier problem). <BR><BR>I&#039ve searched through this entire board, and most people have said either the database is currently open or the permission settings are incorrect. Well, I know for sure the access database is not open, and also, I have been given rights to the directory (on the server) under which both the database and the asp page are stored. Is it possible that I would be able to open the database directly with access, but for some reason can&#039t use explorer to open it from our intranet (where the asp page is stored)?<BR><BR>It would seem that if I can open the database from my computer with Access, that I should be able to open it from my computer using Explorer. But maybe the permission settings are different somehow locally. Anyway, if anyone has an idea why this might be occuring, please let me know what I can do to fix it. Thanks in advance!<BR><BR><BR>By the way, the provider I am using is OLEDB.3.51

  2. #2
    Join Date
    Dec 1969

    Default RE: Connect Error - Permission settings??

    Driver should be 4.00.xx...<BR><BR>install update mdac or access 2K on server

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts