Access Query won't use my function?

Results 1 to 2 of 2

Thread: Access Query won't use my function?

  1. #1
    Michael Wofsey Guest

    Default Access Query won't use my function?

    I have a database of DVD&#039s owned by the library I work for. tblTitles contains a field called Title. When a person displays them on our web site, I want the initial articles removed for sorting but not display purposes. Therefore I&#039ve written a function called Strip which removes "The ", "An ", and "A" from titles. I&#039ve placed Strip in a module in the Access database. When I run a query in Access, the function works perfectly. When I use an ASP page to return the results of that query as opposed to the table, I get an error:<BR><BR>Microsoft OLE DB Provider for ODBC Drivers error &#039 80040e14&#039 <BR><BR>[Microsoft][ODBC Microsoft Access Driver] Undefined function &#039Strip&#039 in expression.<BR><BR>I get the same error if I add the function explicitly to the ASP page or via a #include. However, when the function is included in the ASP page, it works properly if I feed it a string directly:<BR> Strip("The Time has come") returns Time has come<BR><BR>How can I get Strip to work on data in my database table?

  2. #2
    Join Date
    Dec 1969

    Default RE: Access Query won't use my function?

    I don&#039t think you can call a function from within the database from your asp page try putting the function on the page and call it from there.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts