Getting Error loading DLL from ASP but not from VB

Results 1 to 4 of 4

Thread: Getting Error loading DLL from ASP but not from VB

  1. #1
    David A. Pesante Guest

    Default Getting Error loading DLL from ASP but not from VB

    Hi!<BR><BR>I am running into a problem that has manifested in more than one machine Basically, we developed an Active-X DLL in Visual Basic 5.0 (SP3) and install it on our NT server to be used from our ASP scripts. After installing and registering the Active-X DLL everything worked fine. This morning we rebooted the server and now we are getting the following error from our ASP page (no changes were done, really!!). <BR><BR>Error Number: 48<BR>Err Description: Error in loading DLL.<BR>Source: MW_VTermDef (&#060;- This is the name of our Active-X DLL)<BR><BR>The weird thing is that we have some VB programs that also use the same Active-X control and they work fine. I went to the extend of creating a VB program using VB code and also the MS Script Control. This program now contains the same VBScript code as in our ASP page with the exception that the actual "CreateObject" is not using the Server.CreateObject:<BR><BR> Set VTerm = Server.CreateObject("VTerm.MW_VTerm")<BR><BR> vs<BR> Set VTerm = CreateObject("VTerm.MW_VTerm")<BR><BR>At this point I have no idea as to what could cause the ASP to fail during Server.CreateObject but the VB CreateObject works ok on the same machine!<BR><BR>Any help/Advice would be greatly appreciated!<BR><BR>Regards,<BR><BR>David A. Pesante<BR><BR>----------------------------------------------------<BR>David A. Pesante<BR>Mediaware Technologies Inc.<BR><BR>Office : 800-711-5569<BR>Direct : 904-646-4499<BR>Cel : 904-463-2603<BR>Fax : 801-382-2399<BR>e-mail : pesante@mediaware-tech.com<BR>web : http://www.clientviewbuilder.com<BR><BR>

  2. #2
    sridharm Guest

    Default RE: Getting Error loading DLL from ASP but not fro

    I don&#039t know exactly, but i think the problem is with session<BR>I got the same problem previously. what i did was just i created<BR>a new project and copied the files to the new project and it worked fine. Hope it works for You

  3. #3
    David A. Pesante Guest

    Default RE: Getting Error loading DLL from ASP but not fro

    &#062;&#062;<BR>I don&#039t know exactly, but i think the problem is with session<BR>I got the same problem previously. what i did was just i created<BR>a new project and copied the files to the new project and it worked fine. Hope it works for You<BR>&#060;&#060;<BR><BR>Thanks for the info. <BR>1. With "session" do you mean using Session variables?<BR>2. By "creating a new project" do you mean creating a new VB project. Using same or different name? <BR>3. By "Copy the files to the new project" do you mean just bringing any *.bas to that project. Basically duplicating the project under a new Active-X control DLL file (not necessarily the internal "CreateObject" name!).<BR><BR>I really appreciate your help. I have not run into too many people that had the same problem.<BR><BR>Thanks,<BR><BR>David

  4. #4
    Join Date
    Dec 1969
    Posts
    274

    Default RE: Getting Error loading DLL from ASP but not fro

    Is it possible that file permissions were changed?


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •