database is located in a remote server

Results 1 to 3 of 3

Thread: database is located in a remote server

  1. #1
    keefe Guest

    Default database is located in a remote server

    hi there!<BR><BR>am having trouble in having my asp webpage connect to my database. error message states:<BR><BR>"Microsoft JET Database Engine error &#039 80004005&#039 <BR><BR>The Microsoft Jet database engine cannot open the file &#039\serverdata.mdb&#039. It is already opened exclusively by another user, or you need permission to view its data."<BR><BR>we have already read and tried all articles pertaining to this error such as giving permissions to the IUSR account to the shared folder of the database or setting authentication to basic instead of NTLM but the problem still exist. what&#039s weird is that only the domain administrator account was able to execute the page properly or if we place the database in our web server. however, as per setup, we cannot have our database located in the webserver due to permission issues.<BR><BR>any help will really be appreciated. thanks!<BR>

  2. #2
    Join Date
    Dec 1969

    Default RE: database is located in a remote server

    duuno if this helps. But I had the same problem and it was the IUSR which was the problem. Although it had permissions, it wasnt on the domain properly, so it couldnt access the other machines on the domain. <BR>Also you have to ensure in IIS that the the enable automatic password sync is not ticked, as for some reason this kills it too!<BR>(I had rather a few probelms trying to get it to work with my remote SQLserver, So I sympathise!)

  3. #3
    keefe Guest

    Default RE: database is located in a remote server

    thought i was the only one having the problem. :) we have given full access to the IUSR account in the share and security permissions of the database folder. i have likewise unticked the password synchronization. i have also specified domainIUSR_servername in the username....however, one question i have in mind, would you have any idea what password this account have. according to my reading, this account is automatically generated once IIS is installed, but changing the user in the anonymous access to domainIUSR_servername, i left the password now, i am hoping that this is the one causing the problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts