I am running VB6 and Access 2000. I have installed DCOM98 1.3 and the latest version of the MDAC. When I use 2.1 library I get not supported by the provider error. I have checked msado.dll version and it is 2.10.4202.1. I am not sure what I am missing here. <BR>Any suggestion will be appreciated. <BR> Thanks!