The problem is that I have set up a web with login code & it works on some but not all of the web pages. It will not execute on my default page that is in frames. I have tried putting the code on the container page(default) and also the frames - store.asp and form.htm. My code for the login has 4 components<BR><BR>1. The form - which is your basic code<BR>2. The login.asp<BR><BR>&#060;%<BR>Response.Buffer = True<BR>Dim Cm, RS<BR><BR><BR>Set Cm = Server.CreateObject("ADODB.Command")<BR><BR>Cm.Act iveConnection = "DSN=cogcdsn"<BR><BR><BR>Cm.CommandText = "SELECT * FROM Admin WHERE " &_<BR>"Username=&#039" & Request.Form("Username") & "&#039 AND " &_<BR>"Password=&#039" &_<BR>Request.Form("UserPassword") & "&#039"<BR><BR>Cm.CommandType = 1<BR><BR>Set RS = Cm.Execute<BR><BR>If RS.EOF Then<BR>Session("Authenticated") = 0<BR>Response.Redirect ("Login.htm")<BR><BR>Else<BR><BR>Session("Authenti cated") = 1<BR>Response.Redirect ("default.htm")<BR><BR>End If<BR>%&#062;<BR><BR>3. The code I put on the top of every page in the web:<BR><BR>&#060;%<BR>If Session("Authenticated") = 0 Then<BR>response.redirect("login.htm")<BR>End if<BR>%&#062;<BR><BR>4. And finally my global.asa<BR><BR>&#060;SCRIPT LANGUAGE=VBScript RUNAT=Server&#062;<BR><BR>Sub Session_OnStart<BR><BR><BR>Set Cart = Server.CreateObject ("")<BR>Cart.ConnectString = "cogc"<BR>Cart.StateTaxRate = "7%"<BR>Cart.CountryTaxRate = "7%"<BR>Session("Cart") = Cart.SaveCart<BR>Set Cart = Nothing<BR>Session("Authenticated") = 0<BR>end sub<BR><BR>Sub Session_OnEnd<BR><BR>Set Session("Cart") = Nothing<BR><BR>end sub<BR><BR>&#060;/SCRIPT&#062;<BR><BR>Can someone please take a look<BR>Thanks<BR>