800a01ad ActiveX component can't create object

Results 1 to 2 of 2

Thread: 800a01ad ActiveX component can't create object

  1. #1
    Join Date
    Dec 1969

    Default 800a01ad ActiveX component can't create object

    Hi!<BR>I get the following error when my ASP page tries to read records from the SQL server database via a MTS component. <BR>800a01ad ActiveX component can&#039t create object.<BR>The code works fine in the development environment but on the production environment i get that error message. The only difference between the code in the test/development environment and the production is that I have changed the connectionstring to the new servername and databasename:<BR>Provider=sqloledb;Server=SESSWEBS AM;Database=WEBSAM,Trusted_connection=Yes;RunPromp tBehavior=adPromtNever<BR>I have tried to change all kinds of security settings on the production server but I still get the same error, and yes, the components that handle the database access and the methods are properly registred on the server. Has anyone any idea about what I missed? The code line specified in the error message is not the one with the createobject method but the one when the first method in the object is called. All database accesses are handled by one component which the other components calls.<BR>All suggestions would be greatly appreciated since the system is supposed to be placed into production today!<BR>//Jonas jonas_thornberg@hotmail.com

  2. #2
    Join Date
    Dec 1969

    Default RE: 800a01ad ActiveX component can't create ob

    Have you registered the Active X control on the production server?<BR><BR>Does it work from the server itself? if so, You may need to download it to the client and register it on the client.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts