Field name spaces

Results 1 to 2 of 2

Thread: Field name spaces

  1. #1
    Join Date
    Dec 1969

    Default Field name spaces

    Does anyone know how to represent a field with a space in it when using the addnew method.<BR>I have a database that has field names such as &#039fax number&#039 and I am unable to change the field names to solve this problem.<BR><BR>using the addnew method to insert records i.e<BR><BR>objRS.addnew<BR>objRS("Fax Number") = fax<BR>objRS.update<BR><BR>I receive the syntax error with the insert into statement. Does anyone know the code to show the space in the field name. I have tried using objRS.Fields(2).value to no avail.<BR>I have tried using objRS.addnew "fax number", fax - but this didn&#039t work either<BR><BR>Your help would be most appreciated<BR>Cheers

  2. #2
    Join Date
    Dec 1969

    Default RE: Field name spaces

    If this is Access<BR><BR>objRS.addnew<BR>objRS([Fax Number]) = fax<BR>objRS.update<BR><BR>should work. If it were SQL Server or Oracle, what you had to begin with looks correct.<BR><BR>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts