Recordset.Find gone wrong

Results 1 to 5 of 5

Thread: Recordset.Find gone wrong

  1. #1
    Join Date
    Dec 1969
    Posts
    28

    Default Recordset.Find gone wrong

    Hi all,<BR>I need to find multiple records, to assign contacts to a cookie, yet &#039find&#039 will not move the record to another. The other records are there, yes, and I have it set to dynamic as well. What could possibly be the problem? <BR><BR>objRec.MoveFirst<BR>ObjRec.Find "contact = " & contactcode & "1"<BR>If not objRec.EOF then<BR>Response.Cookies("Online")("Contact1") = objRec("name")<BR>End If<BR><BR>And then I repeat the code the same way, only loop with number 2, and so on. Any suggestions appreciated.<BR>-Mitch

  2. #2
    lagerBoy Guest

    Default RE: Recordset.Find gone wrong

    You nearly had it!<BR><BR>Try this - ObjRec.Filter "contact = " & contactcode & "1"<BR><BR>

  3. #3
    Join Date
    Dec 1969
    Posts
    28

    Default It still won't work...

    Thank you for your input, largerboy, but objRec.Filter achieves the same the thing as objRec.Find- nothing. If I can supply more core/information to clarify, please ask.<BR>-Mitch

  4. #4
    lagerBoy Guest

    Default RE: It still won't work...

    Try using a client-side cursor:<BR><BR> objRec.CursorLocation = 3


  5. #5
    Join Date
    Dec 1969
    Posts
    28

    Default I think that somehow did the trick!

    Thanks, I appreciate it- now I&#039m going to go maul over why that worked and the other bit didn&#039t. Thank you for helping me out-<BR>-Mitch

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •