Unspecific error when opening DSN

Results 1 to 2 of 2

Thread: Unspecific error when opening DSN

  1. #1
    Portrman Guest

    Default Unspecific error when opening DSN

    Hi all, I am so lost on this one. This is the error message I get.<BR>Error Type:<BR>Provider (0x80004005)<BR>Unspecified error<BR>/testing.asp, line 8<BR><BR>Line is is here.<BR>SET cn = Server.CreateObject("ADODB.connection")<BR>cn.Open "DSN=portrman-Website1" &#060;---------this line<BR>SET Items = Server.CreateObject("ADODB.Recordset")<BR><BR>This is a System DSN with all defaults, all I have specified is the name, description and database location. I have tried it with and without the "-" in the DSN name.<BR><BR>This happens usually after a few hours of work. I would have my webpage up on my comp then hit refresh after making some changes, which had absolutely nothing to do with this, like a color change or something. Upon refresh(F5) I would get this error. If I try to refresh again imiadietly it would still be there. If I wait about 2-3 minutes and hit refresh again, my webpage comes back. But then if I hit refresh imiatietly again, the error comes back. The only thing I can think of is the number of connection allowed, except I am the only one that can access this page.<BR><BR>The only way I can get rid of this after it starts to happen is to reboot my machine! What am I doing wrong?!<BR><BR>I am running win2k with IIS5.0 PWS<BR>This error occurs on a my computer and 2 friends computers with same OS and PWS installed.<BR><BR>Also, it does not matter what code I have, it does it even on a simple hello world page that only opens and closes the connection, but doesn&#039t actually take anything from it.<BR><BR>This error however does not alway happen either. Occasionally I can work for 5-6 straight with no probs. I am a newbie, but as far as I can tell I&#039m not doing anything wrong. I close my connection and set them to "NOTHING"<BR><BR>Thanks alot in advance for the help, I have lost hours of development time waiting for my page to let me refresh.<BR><BR>email: portrman@hotmail.com

  2. #2
    Portrman Guest

    Default RE: Unspecific error when opening DSN

    Here is a little tidbit I forgot to mention.<BR>Just above the error message that I previously mentioned I get this, but really don&#039t understand. Because my asp seems fine after a refresh after 2-3 mins of waiting<BR><BR>HTTP 500.100 - Internal Server Error - ASP error<BR>Internet Information Services<BR><BR>Thanks again for any info

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts