WAP problem Response.redirect(URL)

Results 1 to 3 of 3

Thread: WAP problem Response.redirect(URL)

  1. #1
    hungry m Guest

    Default WAP problem Response.redirect(URL)

    For my login page I check a password against one in a database,<BR>if it fits, I redirect the user to the welcome page like this:<BR><BR> Response.redirect ("welcome.asp")<BR><BR>This same thing works fine for html pages, however if I use this for a wml page, when the password fits, I just get an &#039object moved error&#039.<BR><BR>I notice none of the ASP/WAP tutorials I have seen use this method which I find a bit weired, can you not do this with WAP?<BR><BR>(I haven&#039t tried this with a real WAP phone, just using the emulator thing at wapsilon.com and also the one at wapdrive.com, so maybe this is where the problem is. The page is served from ewebcity.com)<BR><BR>Thanks in advance if any one has any knowledge on this, hm<BR><BR>

  2. #2
    Join Date
    Dec 1969

    Default RE: WAP problem Response.redirect(URL)

    I have no clue about anything wap-related really, but try taking off the brackets from response.redirect..<BR><BR>ie: it should be: response.redirect "homepage.asp"<BR><BR>probably won&#039t affect anything but who knows.. if you want to know why, then you have to sift thru correct calling of functions and stuff...<BR><BR>i think if you want to use the brackets you probably have to put `call` infront..<BR><BR>it&#039s because response is a function..<BR><BR>anyways luk!

  3. #3
    Join Date
    Dec 1969

    Default RE: WAP problem Response.redirect(URL)

    Nah - it&#039s sending the redirect or you wouldn&#039t see "Object moved..." - it&#039s just that the browser isn&#039t using the redirect in the way NS and IE do.<BR><BR>Dunc

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts