Moving data bewteen tables w/ ADO

Results 1 to 3 of 3

Thread: Moving data bewteen tables w/ ADO

  1. #1
    rossman Guest

    Default Moving data bewteen tables w/ ADO

    This is the error:<BR><BR>Multiple-step OLE DB operation generated errors. Check each OLE DB status value, if available. No work was done.<BR><BR>Here&#039s the code:<BR><BR> rsSecurityInfo.AddNew<BR> rsSecurityInfo("UserName") = strUserName<BR> rsSecurityInfo("Password") = strPassword<BR> rsSecurityInfo.Update<BR> <BR> rsPersonalInfo.AddNew<BR> rsPersonalInfo("PersonalID") = rsSecurityInfo("PersonalID") &#039the problem is here, but I don&#039t know why<BR> rsPersonalInfo("FName") = strFName<BR> rsPersonalInfo("LName") = strLName<BR> ...<BR> rsPersonalInfo.update<BR><BR>The PersonalID field is set as Identity (int) in rsSecurityInfo. The IDs in the rsSecurityInfo table are there, but it won&#039t pull it to the rsPersonalInfo table. Does anyone see why? I see other examples like this that work fine, I don&#039t know what I&#039m doing wrong. It acts like its trying to pass a null value. I&#039m using SQL 7.

  2. #2
    MG Guest

    Default RE: Moving data bewteen tables w/ ADO

    Try setting rsSecurityInfo("PersonalID") = variable and then assign the variable to the new table<BR>ie:<BR>variable = rsSecurityInfo("PersonalID")<BR>....<BR>rsPersonal Info("PersonalID") = variable

  3. #3
    rossman Guest

    Default Tried that...Still stumped

    I tried that and it gave the same error. Any other ideas? I&#039m totally stumped

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts