ActiveX Components and DLLs in Use

Results 1 to 2 of 2

Thread: ActiveX Components and DLLs in Use

  1. #1
    Vinnie Guest

    Default ActiveX Components and DLLs in Use

    Dear Ladies and Gentlemen:<BR><BR>I am developing an ActiveX object to do some encryption and some data formatting, in Visual C++.<BR><BR>The problem is, when I link, the DLL is usually in use from my previous execution session.<BR><BR>When I NET STOP W3SVC, it works, but when I go to restart it with NET START W3SVC, I see a bunch of dots, and I get an error 1068.<BR><BR>I&#039ve tried NET STOP IISADMIN /Y instead, the same thing happens.<BR><BR>After this happens, the Web service is in limbo..the Start button is disabled in the Services Control Panel.<BR><BR>I&#039ve even tried re-installing EVERYTHING (NT4 Standalone Server Enterprise, Back Office 4.5) from a clean reformatted NTFS partition and that didn&#039t solve the problem.<BR><BR>I HATE rebooting every time I make a one line change!<BR><BR>PLEASE HELP!<BR><BR>my email is vfalco@appbase.com<BR><BR>Vinnie<BR><BR><BR>

  2. #2
    Richard L. Guest

    Default RE: ActiveX Components and DLLs in Use

    You can try this:<BR><BR>Setup a virtual folder under the web service you&#039re intstantiating your object(s) in this DLL and put the page(s) that call the DLL in there. Then under the properties of this virtual directory (the same page you allow script / execute access on) click the "run in separate memory process" (or something like that). <BR><BR>Then, each time you want to &#039release&#039 your DLL.. hit the Unload button on the same page. This *might* work.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •