DSN not found/no default driver specified

Results 1 to 4 of 4

Thread: DSN not found/no default driver specified

  1. #1
    Hardy Guest

    Default DSN not found/no default driver specified

    What&#039 could possibly be the problem?<BR>I have checked all the following:<BR>1.) My DSN is correctly spelled<BR>2.) It is registered in the Local Machine hive<BR>3.) I do have the latest MS ACCESS driver installed along with the MDAC 2.5<BR>

  2. #2
    Markkk Guest

    Default RE: DSN not found/no default driver specified

    1. make sure that the DSN was setup as a "System DSN", not as a File or User DSN.<BR><BR>2. Make sure that appropraite NTFS permissions are given to allow IIS to READ and CHANGE the database file. Also, make sure that appropriate permissions are given to IIS to CREATE and DELETE files in the database directory. Keep in mind that whenever IIS attempts to open an ACCESS database, a locking file (*.ldb) must be created. If IIS doesn&#039t have permission to CREATE and DELETE the locking file, then no database connection will occur.<BR><BR>If the ACCESS database is being connected via a page using Anonymous Authentication, then IIS will use the "IUSR_Machninename" account (default). If youn are Authenticating you web clients, then the authenticated clients Accounts must have READ, CHANGE, CREATE and DELETE permissions as well.<BR><BR>If you still have problems, POST YOUR CODE!<BR><BR>I hope this helps!!!

  3. #3
    Markkk Guest

    Default RE: DSN not found/no default driver specified

    3. make sure that the database is on the same server as the web server. If the database is on another server on the network, you have a whole slew of other problems dealing with impersonation, delegation and security issues.<BR><BR>if you are not familiar with these issues, please read Microsoft&#039s whitepaper on the issue:<BR><BR>http://msdn.microsoft.com/workshop/server/feature/security.asp

  4. #4
    Hardy Guest

    Default RE: DSN not found/no default driver specified

    I made sure all 3 suggestions were checked over, and they are set correctly.<BR><BR>I&#039m still getting the same error. Weird situation, I was able to create System DSN just fine last week, and those are still working . However, even if I copy the same database and attempt to create a System DSN with a different name, I get an error.<BR><BR>I also attempted to create a DSN-less connection,and again I got the same error.<BR><BR>I installed the MS Data Access Com early this week. I noticed that the MS Access DB driver is version 4.00.4403.02<BR>and the DB Driver Manager is 3.520.4403.2, could this be and issue.<BR><BR>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts