ActiveX Component Can't Create Object

Results 1 to 4 of 4

Thread: ActiveX Component Can't Create Object

  1. #1
    Bill Beattie Guest

    Default ActiveX Component Can't Create Object

    A puzzling problem on my NT machine. I cannot instantiate in process dll&#039s using "Set object = Server.CreateObject("myObject")". The error I get is the usual, "ActiveX component can&#039t create object". This error usually happens when the dll is not correctly registered using regsvr32.exe or if there is a typo in the class name, however this is not the case. <BR><BR>Strangely, the same dll&#039s have been working fine for months and now all of sudden they just stopped working. I can set ADODB.Recordsets and Scripting.FileSystemObject ok, there isn&#039t any other code that is interfering with the "Set object", and there have been no changes except an update to the NetShield virus software I use.<BR><BR>I&#039m guessing that there is a registry setting like "allowInProcCmpnts" or "allowOutOfProcCmpnts" that was changed somehow, but I have searched my registry and cannot find this setting.<BR><BR>Without having to rebuild my entire box, can anyone provide any more efficient ideas? Thanks.

  2. #2
    SPG Guest

    Default Possible Solution Method

    Here&#039s what I did in a similar situation... The situation may not be exactly the same, but -- if you&#039re lucky -- the solution will be the same.<BR><BR>1) Create an audit policy which picks up "Object Access Failure" (your verbiage may vary, I&#039m on Win2K)<BR>2) Start this audit routine over your complete system, especially the \winntsystem32 directory. (this is under Windows Explorer -&#062; "C:\" -&#062; properties -&#062; security -&#062; advanced -&#062; auditing in win2k)<BR>3) Generate the error.<BR>4) Go to your event viewer and the file which was throwing the error in reality should be in the security log. In my case, it was a VB support file which the VB installer had munched. <BR>5) Anyway, find grab that file and clean up its ACLs (security settings). Hopefully your problem is solved.

  3. #3
    Jeff Friestman Guest

    Default RE: ActiveX Component Can't Create Object

    Which dll? Is it one you&#039ve written? If so, make sure all the references in the project are current. For example, I&#039ve written many dlls and I often use them together. If I make changes to one and recompile it, all other projects that use the recompiled dll will now have MISSING: in the Project References dialog for the recompiled dll. The solution in this case is to uncheck the MISSING checkbox, recheck it and recompile the second dll. Good luck.<BR><BR>Jeff Friestman<BR>Brainbench &#039Most Valuable Professional&#039 for ASP<BR><BR>

  4. #4
    Bill Beattie Guest

    Default I found it!

    I changed the I_USER permission on the drive where the dll was registered. This caused I_USER to not be able to see the correctly registered dlls which had worked before.<BR><BR>I was worried about nosy people looking at the data on my hard drive. If this ever happens to anyone, check the permission settings.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts