ODBC Drivers error ' 80004005'

Results 1 to 4 of 4

Thread: ODBC Drivers error ' 80004005'

  1. #1
    Join Date
    Dec 1969

    Default ODBC Drivers error ' 80004005'

    Hi there,<BR><BR>I have been having some spasmodic connection problems when using the ODBC to connect to an access database. the error I get is:<BR><BR>Microsoft OLE DB Provider for ODBC Drivers error &#039 80004005&#039<BR><BR>[Microsoft][ODBC Microsoft Access Driver] Could not use &#039(unknown)&#039; file already in use.<BR><BR>Now this error was not occuring locally when testing on an NT server. but when uploading to a NT server (where the site is hosted) I start getting these errors.<BR>I have noticed that I have to close each connection that i make to the database otherwise the connection "locks" and I get that error!<BR><BR>Is this because i have failed to set up the folder where this site resides properly? I m bewildered as to why one location works and the other doesnt.<BR><BR>Any comments would be greatly appreciated,<BR><BR>Matt<BR><BR>

  2. #2
    Join Date
    Dec 1969

    Default RE: ODBC Drivers error ' 80004005'

    you should always close your connections anyway, as good coding parctice. I&#039ve had this error a couple of times, it seems to be partly dependent on the system you&#039re using for webserver/fileserver config. are you using DSN or DSN-less? (you should use DSN-less for better performance)<BR><BR>jason

  3. #3
    beefturkey Guest

    Default RE: ODBC Drivers error ' 80004005'

    I had that problem once. Make sure you have enough rights to access the folder where your MS-Access database is. <BR><BR>

  4. #4
    Becky Guest

    Default RE: ODBC Drivers error ' 80004005'

    I had a similar problem. We changed the permissions for the database for the user profile &#060;IUSR_machinename&#062; and it worked.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts