HTTP_REFERER does not work

Results 1 to 5 of 5

Thread: HTTP_REFERER does not work

  1. #1
    Josh Rolfe Guest

    Default HTTP_REFERER does not work

    I cannot get request.ServerVariables("HTTP_REFERER") to work. I know it won&#039t work if the URL is typed in directly, but I can&#039t get it to work under any circumstances. In fact, when I use code to loop through and list every item in the serverVariables collection, HTTP_REFERER is not even listed, like the item doesn&#039t even exist. I am using IIS 5.0 on Windows 2000, but I don&#039t know if that has anything to do with it. Any ideas?

  2. #2
    cryogen Guest

    Default RE: HTTP_REFERER does not work

    try using: request.ServerVariables("URL")<BR>this will give the same result i believe.....<BR>hope it helps<BR>

  3. #3
    cryogen Guest

    Default oops

    that will give your current page! doh!<BR>momentary lapse of reason........ ;-)<BR>im having problems w/ http_referrer to, for some reason it is not working for me either.......<BR>try: request.servervariables("script_name")

  4. #4
    Josh Rolfe Guest

    Default RE: oops

    script_name just returns the name of the current asp page - if the code request.serverVariables("SCRIPT_NAME") is on, then "default.asp" is returned.

  5. #5
    cryogen Guest

    Default RE: oops

    yes, i found that out <BR>/me is embarrassed! hehehe<BR>its actually request.servervariables("HTTP_referer")<BR>:)<BR>i tried it, it werks. hehehe<BR>cryogen

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts