forms authentication issue

Results 1 to 2 of 2

Thread: forms authentication issue

  1. #1
    Join Date
    Dec 1969

    Default forms authentication issue

    Hello, <BR><BR>Even thought I have my web.config set like this: <BR>&#060;authentication mode="Forms"&#062; <BR> &#060;forms loginUrl="my_url_here" protection="All" timeout="100" /&#062; <BR>&#060;/authentication&#062; <BR><BR>... and even though at this help file: <BR>ms-help://MS.VSCC.2003/MS.MSDNQTR.2003FEB.1033/cpguide/html/cpconaspnetarchitecture.htm <BR><BR>... it confirms that the timeout attribute is in minutes: <BR><BR>&#060;authentication mode="[Windows&#124Forms&#124Passport&#124None]"&#062; <BR> &#060;forms name="[name]" <BR> timeout="[minutes]"&#062; <BR> &#060;/forms&#062; <BR>&#060;/authentication&#062; <BR><BR>.... my app session times out after just a few minutes. I see this because it keeps sending me through the auto-logon routine. <BR><BR>I tried setting the IE security settings higher (to prompt for first and thrid-party cookies being set) and I tried checking and unchecking the checkbox that says "Always allow session cookies". I no case does it prompt me when the FormsAuthentication.SetAuthCookie() is called. I also deleted everything from "Temporary Internet Files" and watched as I logged in, then refreshed that dir and no cookies show up there. <BR><BR>I also did this: <BR>--------------------------------- <BR>private void Page_Load(object sender, System.EventArgs e) <BR>{ <BR> testLabel.Text = FormsAuthentication.FormsCookiePath + FormsAuthentication.FormsCookieName; <BR>} <BR>--------------------------------- <BR>... and here is what it output: <BR><BR>/.ASPXAUTH <BR><BR>I searched for .ASPXAUTH and it is nowhere on my C drive. <BR>--------------------------------- <BR>I set my web.config: <BR>&#060;authentication mode="Forms"&#062; <BR> &#060;forms loginUrl="Includes/Login.aspx" protection="All" timeout="10000" /&#062; <BR>&#060;/authentication&#062; <BR><BR>.. to 10000 which should translate to 166+ hours if it is doing what it is supposed to, and if it is reading seconds, then it would be 166+ minutes. <BR>--------------------------------- <BR><BR>Does anyone have any thoughts on why this might happen and how I might be able to fix it? <BR><BR>Also, does anyone you know how can I see what the SetAuthCookie() cookie is being set to for time? <BR><BR>tx, <BR>k <BR>

  2. #2
    Join Date
    Dec 1969

    Default RE: forms authentication issue

    First thing, I&#039;d check in your event log right after your session resets to see if your ASP.Net worker process is being recycled.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts