Connecting my Access97 DB to ASP through an Intran

Results 1 to 2 of 2

Thread: Connecting my Access97 DB to ASP through an Intran

  1. #1
    Jason Towne Guest

    Default Connecting my Access97 DB to ASP through an Intran

    *<BR>I&#039m having trouble connecting my ASP page to a database I created. The page allows users to search for a particular person and get their phone number within the company. I&#039m trying to post this on the Intranet where we already have one Access97 DB tied to some other ASP pages that works fine. Do I have to modify the Global.asa file to use more than one DB on the site? The error message I keep getting is below along with the script I&#039ve been using to connect to my DB in my ASP page. I&#039ve tried using a DSNless connection below and that hasn&#039t worked. I&#039ve also tried using Server.MapPath to point directly to the DB and that hasn&#039t worked either.<BR><BR>Microsoft OLE DB Provider for ODBC Drivers error &#039 80004005&#039 <BR><BR>[Microsoft][ODBC Microsoft Access Driver] The Microsoft Jet database engine cannot open the file &#039(unknown)&#039. It is already opened exclusively by another user, or you need permission to view its data. <BR><BR>Set MyConn=Server.CreateObject("ADODB.Connection")<BR> &#039MdbFilePath = Server.MapPath("phone.mdb")<BR> &#039&#060;-----Troubleshooting-------------------&#062;<BR> &#039Response.Write MdbFilePath<BR> &#039&#060;---------------------------------------&#062;<BR> MyDSN = "Driver={Microsoft Access Driver (*.mdb)};"<BR> MyDSN = MyDSN & "DBQ=//spweb/intranet/data/phone.mdb"<BR> MyConn.Open MyDSN<BR><BR><BR>Thanks a bunch all!<BR><BR>Jason<BR>

  2. #2
    Join Date
    Dec 1969

    Default RE: Connecting my Access97 DB to ASP through an In

    I shall take a guess at this and say it has something to do with IUSR_ account. Since your going to a different machine, the IUSR accounts would be different and the machine where your web server is, doesn&#039t have rights to the machine where the DB is. It&#039s just a guess!!! BTW, to map you need backslashes () not forward slashes (/).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts