Sub Session_OnEnd - not running!

Results 1 to 3 of 3

Thread: Sub Session_OnEnd - not running!

  1. #1
    Rupert Guest

    Default Sub Session_OnEnd - not running!

    I have some code, which writes to a file the time the last person left the site! Anyway it doesn&#039t seem to run, I&#039ve searched the whole server to check the file hasn&#039t be stored else where, but no luck there.<BR><BR>I use the code session.abandon to end the session, and the code below sits happily in my global.asa - I also know that the web-application has seen the global.asa file as it initalizes the session variables correctly.<BR><BR><BR>Sub Session_OnEnd<BR><BR>whichname=" empfile.txt"<BR> whichdir=Server.Mappath ("excel\")<BR> whichFN=whichdir & whichname<BR> <BR> &#039 first, create the file out of thin air<BR> <BR> Set fstemp = server.CreateObject("Scripting.FileSystemObject")< BR> Set filetemp = fstemp.CreateTextFile(whichFN, true)<BR><BR> <BR> filetemp.WriteLine("last user:" & now())<BR> filetemp.writeblanklines(3) filetemp.Close <BR>end sub<BR>

  2. #2
    Join Date
    Dec 1969

    Default RE: Sub Session_OnEnd - not running!

    I don&#039t think it&#039s your code. I&#039ve never gotten a Session_OnEnd to do everything I wanted; supposedly this was fixed in Win2K.

  3. #3
    Rupert Guest

    Default RE: Sub Session_OnEnd - not running!

    Thanks for your feedback - I&#039m running the app on NT with SP5, maybe I&#039ll work an alternative solution to my problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts