Hi <BR>I am working on crystall reports in ASP.net.When try to connect my local sqlserver using sa account my report is working fine.<BR>When i try connect anothe sql server (which is reside on some other machine) using window authentication i am getting invalid table number error.When i debug my code its giving error at CrTable.Location line.here i am giving my code pl pl help me.<BR><BR>thanks <BR><BR>Dim rptAttendance As New ReportDocument<BR>Dim strDBServer As String<BR>Dim strDBName As String<BR>Dim strUserName As String<BR>Dim strPassword As String<BR>Dim strReportFilePath As String<BR>Dim crtableLogoninfos As New TableLogOnInfos<BR>Dim crtableLogoninfo As New TableLogOnInfo<BR>Dim crConnectionInfo As New ConnectionInfo<BR>Dim CrTables As Tables<BR>Dim CrTable As Table<BR>Dim TableCounter<BR><BR>Dim crReportDocument As New ReportDocument<BR>strReportFilePath = Request.MapPath("").ToString<BR>strReportFilePath = strReportFilePath & "\" & "test2.rpt"<BR>crReportDocument.Load(strReportFile Path)<BR><BR>strDBServer = "Acc"<BR>strDBName = "Sales"<BR><BR>With crConnectionInfo<BR>.ServerName = strDBServer<BR>.DatabaseName = strDBName<BR>End With<BR><BR>CrTables = crReportDocument.Database.Tables<BR><BR>&#039;Loop through each table in the report and apply the <BR>&#039;LogonInfo information <BR><BR>For Each CrTable In CrTables<BR>crtableLogoninfo = CrTable.LogOnInfo<BR>crtableLogoninfo.ConnectionIn fo = crConnectionInfo<BR>CrTable.ApplyLogOnInfo(crtable Logoninfo)<BR>CrTable.Location = strDBName & ".dbo." & CrTable.Location.Substring (CrTable.Location.LastIndexOf(".") + 1)<BR>Next<BR>CrystalReportViewer1.DisplayToolbar = True<BR>CrystalReportViewer1.DisplayPage = True<BR>CrystalReportViewer1.DisplayGroupTree = False<BR>CrystalReportViewer1.ReportSource = crReportDocument<BR>