Hi guys,<BR><BR>I&#039ve just started programming in ASP (still in my first week, errrm, with no VBscript experience), I&#039ve got some mail code here from my predecessor. It works fine on the live webserver (I receive an e-mail), but when I work with it on our development server I get an error like this. <BR><BR>****************************************** *<BR>Server object error &#039ASP 0177 : 800401f3&#039 <BR><BR>Server.CreateObject Failed <BR><BR>/maillist/sendtomaillist.asp, line 42 <BR><BR>Invalid class string <BR><BR>*****************************<BR><BR>Can anyone tell me why this is happening, here is a snippet of the code where it appears to be falling over, I hope I paste in enough.<BR><BR>******************************<BR>d im redirect,subject,body,fromname,fromaddress,mailer, myGroup<BR><BR>redirect = StripHTMLTag(request.form("redirect"))<BR>subject = StripHTMLTag(request.form("Subject"))<BR>myGroup = request.form("myGroup")<BR>&#039body = StripHTMLTag(request.form("Content"))<BR>body = request.form("Content")<BR>fromname = request.form("fromname")<BR>fromaddress = request.form("fromaddress")<BR><BR>Set Mailer = Server.CreateObject("SMTPsvg.Mailer")<BR>Mailer.QM essage = true<BR><BR>Mailer.FromName = fromname<BR>Mailer.FromAddress = fromaddress<BR>Mailer.RemoteHost = ""<BR>Mailer.Subject = subject<BR>Mailer.BodyText = body<BR>&#039Mailer.ContentType = "text/html" <BR>*******************************<BR><BR>Any help would be much appreciated, thanks in advance, you can contact me at nathan@tsw.com.au.<BR>I got replies from the Q & A section saying to install the appropriate components on the development server, how does one do this?? Can anyone tell me or tell me of an appropriate link that could help? I&#039ve also come across another createobject that doesn&#039t work on the dev server. <BR>In another file this function OpenSite seems to create okay<BR><BR>Function OpenInsite<BR>Set insiteCONN = Server.CreateObject("ADODB.connection")<BR>insiteC ONN.open "edcreditinsite"<BR>End Function<BR><BR>but when it comes to creating this upl object<BR><BR>set upl = Server.CreateObject("SoftArtisans.FileUp")<BR>acti on = upl.Form("action")<BR>pid = upl.form("pid")<BR>posID = upl.form("posID")<BR><BR>it gets the same sort of error as above, I really need to figure out how to get these components going, any help would be great.<BR><BR>Cheers,<BR>Nathan <BR><BR>