Site text Search Engine

Results 1 to 2 of 2

Thread: Site text Search Engine

  1. #1
    Terry Hayes Guest

    Default Site text Search Engine

    Hi,<BR><BR>I&#039ve tried endlessly to get the boolean text search like the one on this site to work on my server but I just can&#039t make it happen.<BR><BR>First, I&#039m not sure I&#039m getting the path right...the ISP says the path to my site is e:virtwww
    crad .... so I used this at the start of the script:<BR><BR>&#039Cut off everything before virtwww and replace all with /<BR> Dim iPos<BR> iPos = InStr(1,strPath,"virtwww",1)<BR><BR>Doesn&#039t seem to work though.<BR><BR>Also when specifying the kind of files to search, I&#039m not sure I have used the right syntax with the following:<BR><BR> If UCase(Right(objFile.Name,6)) = ".HTML",".HTM",".ASP" then ....etc<BR><BR>Lastly, my dropdown list of folders on the search interface contains an option for the root directory of the site and 4 subs which I would access with the following URLs respectively:<BR><BR><BR><BR><BR><BR><BR><BR> I have used the following for selSearchWhere...<BR><BR> Dim section<BR> section = Request("selSearchWhere")<BR> <BR> &#039Get the dirs to search<BR> If section = "College" then<BR> section = Server.MapPath("../")<BR> <BR> Elseif section = "RadiologyPubs" then<BR> section = Server.MapPath("../radiology/publications/")<BR><BR> Elseif section = "OncologyPubs" then<BR> section = Server.MapPath("../oncology/publications/")<BR><BR> Elseif section = "RadiologyMeetings" then<BR> section = Server.MapPath("../radiology/meetings/")<BR><BR> Else<BR> section = Server.MapPath("../oncology/meetings/")<BR> <BR> end if<BR><BR>I don&#039t actally get errors but I always get no matches found so I guess I&#039ve screwed up. Also I had to takeout the line &#060;% OPTION EXPLICIT %&#062; because this was causing an error.<BR><BR>Can anyone please offer some wisdom? It would be hugely appreciated.<BR><BR>Thanks,<BR><BR>Terry H<BR>

  2. #2
    Andrew Downie Guest

    Default RE: Site text Search Engine

    Terry,<BR><BR>I am having the exact same problem as you and have been working at this and some other scripts all day. I too had the problem with the Option Explicit.<BR><BR>I am actually getting the search engine working. But only to a limited extent. I can only get it to search for .SHTML why? i don&#039t know. The other commands .asp .html do not work. <BR><BR>I got rid of the different directories as it just seemed to complicate the script. I have copied one of the help files into the root directory and called them 1.shtml and 2.shtml. Go to the website that i have this thing testing on.<BR><BR>Search for something like "article". It should come up with the same article 2 times as it is a different file name. This means that the basics behind the search engine work. The only REAL problem is getting the correct link as it goes to: when it should go to 1.shtml<BR><BR>Now the directory off the server is \downieakisssearch so i can sea where it has got the NIEA from as it is the end of dowNIEA and it has given the full path for some reason. I can&#039t work it out. Please give me an e-mail with any ideas of what you think is the problem. E-mail me at:<BR><BR>I will get back to you right away. I need this thing workign ASAP on a huge site.<BR><BR>Regards<BR><BR>Andrew Downie

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts