Some Help with Connections Please

Results 1 to 2 of 2

Thread: Some Help with Connections Please

  1. #1
    Join Date
    Dec 1969

    Default Some Help with Connections Please

    Either I am being really stupid... or my ASP programming skills have left me!<BR><BR>I have, for the last couple of hours, been trying to create an ASP page (just to get back into practise). I have created a database (on Access) and am trying to connect to it (on my PC). I have started IIS etc and I get an error stating the following:<BR><BR><BR>Microsoft OLE DB Provider for ODBC Drivers (0x80004005)<BR>[Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified<BR>/test/test.asp, line 20<BR><BR><BR>Now this is related to the point where I try to connect to the database, I am using the following piece of coding:<BR><BR>************<BR>Dim objConn, rs, strsql<BR><BR>set objConn = server.CreateObject("ADODB.Connection")<BR>objConn .ConnectionString = "DBQ=c:/inetpub/wwwroot/test/films.mdb;DRIVER={MS Access (*.mdb)}"<BR>objConn.Open<BR><BR><BR>strsql="selec t * from Film where name = &#039;OE&#039;"<BR><BR>set rs = server.CreateObject("ADODB.Recordset")<BR>set rs = objConn.Execute (strsql)<BR>************<BR><BR>Could this have anything to do with the fact I am using Windows XP?<BR><BR>Also, I have also tried to connect with a DNS connection and I get the same problem.<BR><BR>Any help would be greatly appreciated.<BR><BR>Thanking you all in advance and apologies for the length of this post!

  2. #2
    Join Date
    Dec 1969

    Default RE: Some Help with Connections Please

    Change your connection string.....<BR><BR>oConn.Open "Provider=Microsoft.Jet.OLEDB.4.0;" & _<BR> "Data Source=c:inetpubwwwroot estfilms.mdb;"<BR><BR>also, the file system uses (backslash) NOT / (forwardslash)<BR>PS, that may be all it is......<BR><BR>HTH.<BR>D.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts