Sorry i won&#039t be able to help you, but I don&#039t even get as far as you do...<BR><BR>My problem is the same error 80004005, but it returns the error: Operation must use an updatable query.<BR>Could it be an error in NT because, it works with the PWS<BR>I&#039m using a Acces 97 DB and NT 4 SP4<BR><BR>Any help is appreciated<BR><BR>Tnx Rim